summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2021-07-07 15:17:40 +0200
committerPaolo Bonzini2021-07-09 18:21:34 +0200
commitf4063f9c319e3924b0c6d09dfe43e94d01253ee0 (patch)
tree026bf68d89c0eb5e89318ce77b83f669fc1ec020 /meson.build
parentmeson: switch function tests from compilation to linking (diff)
downloadqemu-f4063f9c319e3924b0c6d09dfe43e94d01253ee0.tar.gz
qemu-f4063f9c319e3924b0c6d09dfe43e94d01253ee0.tar.xz
qemu-f4063f9c319e3924b0c6d09dfe43e94d01253ee0.zip
meson: Introduce target-specific Kconfig
Add a target-specific Kconfig. We need the definitions in Kconfig so the minikconf tool can verify they exits. However CONFIG_FOO is only enabled for target foo via the meson.build rules. Two architecture have a particularity, ARM and MIPS. As their translators have been split you can potentially build a plain 32 bit build along with a 64-bit version including the 32-bit subset. Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20210131111316.232778-6-f4bug@amsat.org> Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Reviewed-by: Thomas Huth <thuth@redhat.com> Message-Id: <20210707131744.26027-2-alex.bennee@linaro.org> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5a56e3fe2f..d82f7a789d 100644
--- a/meson.build
+++ b/meson.build
@@ -1604,7 +1604,8 @@ foreach target : target_dirs
command: [minikconf,
get_option('default_devices') ? '--defconfig' : '--allnoconfig',
config_devices_mak, '@DEPFILE@', '@INPUT@',
- host_kconfig, accel_kconfig])
+ host_kconfig, accel_kconfig,
+ 'CONFIG_' + config_target['TARGET_ARCH'].to_upper() + '=y'])
config_devices_data = configuration_data()
config_devices = keyval.load(config_devices_mak)