summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-08-05 15:49:10 +0200
committerPaolo Bonzini2020-08-21 12:30:41 +0200
commitf8aa24ea9a82da38370470c6bc0eaa393999edfe (patch)
tree04db2c0cd380403f5d50a7605f79dbae5bf00661 /meson.build
parentremove Makefile.target (diff)
downloadqemu-f8aa24ea9a82da38370470c6bc0eaa393999edfe.tar.gz
qemu-f8aa24ea9a82da38370470c6bc0eaa393999edfe.tar.xz
qemu-f8aa24ea9a82da38370470c6bc0eaa393999edfe.zip
meson: sphinx-build
For now, sphinx is run on every invocation of make. The previous mechanism using $(wildcard) is not reproducible in Meson and was also brittle; for example some .rst.inc files were left out. The next patch will introduce a Sphinx extension to emit a depfile. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 108706f7e5..e270569f4d 100644
--- a/meson.build
+++ b/meson.build
@@ -11,6 +11,7 @@ cc = meson.get_compiler('c')
config_host = keyval.load(meson.current_build_dir() / 'config-host.mak')
config_all_disas = keyval.load(meson.current_build_dir() / 'config-all-disas.mak')
enable_modules = 'CONFIG_MODULES' in config_host
+build_docs = 'BUILD_DOCS' in config_host
add_project_arguments(config_host['QEMU_CFLAGS'].split(),
native: false, language: ['c', 'objc'])
@@ -1049,6 +1050,7 @@ endif
subdir('tools')
subdir('pc-bios')
subdir('tests')
+subdir('docs')
summary_info = {}
summary_info += {'Install prefix': config_host['prefix']}