summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2022-01-07 13:00:44 +0100
committerPaolo Bonzini2022-01-12 14:09:06 +0100
commitfb72176ba64057ce0ee5c1a0a443d9f72e270636 (patch)
tree069c62c2ca85fb2087f056b5dbd4d5d098340f3d /meson.build
parentconfigure: do not create roms/seabios/config.mak if SeaBIOS not present (diff)
downloadqemu-fb72176ba64057ce0ee5c1a0a443d9f72e270636.tar.gz
qemu-fb72176ba64057ce0ee5c1a0a443d9f72e270636.tar.xz
qemu-fb72176ba64057ce0ee5c1a0a443d9f72e270636.zip
meson: build all modules by default
With more recent versions of Meson, the build.ninja file is more selective as to what is built by default, and not building the modules results in test failures. Mark the modules as built-by-default and, to make the dependencies more precise, also require them to be up-to-date before running tests. Resolves: https://gitlab.com/qemu-project/qemu/-/issues/801 Tested-by: Li Zhang <lizhang@suse.de> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 937658359e..762d7cee85 100644
--- a/meson.build
+++ b/meson.build
@@ -2866,8 +2866,10 @@ common_ss.add(hwcore)
# Targets #
###########
+emulator_modules = []
foreach m : block_mods + softmmu_mods
- shared_module(m.name(),
+ emulator_modules += shared_module(m.name(),
+ build_by_default: true,
name_prefix: '',
link_whole: m,
install: true,