summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-09-16 11:00:53 +0200
committerPaolo Bonzini2020-09-30 19:11:36 +0200
commitfd5eef85fed024387d41adc4f7ca502c14ff62be (patch)
tree49176a00729123b189e5bb159284a52347572ce7 /meson.build
parentconfigure: do not limit Hypervisor.framework test to Darwin (diff)
downloadqemu-fd5eef85fed024387d41adc4f7ca502c14ff62be.tar.gz
qemu-fd5eef85fed024387d41adc4f7ca502c14ff62be.tar.xz
qemu-fd5eef85fed024387d41adc4f7ca502c14ff62be.zip
meson: qtest: set "depends" correctly
This does not have any effect on Meson's behavior itself, since "meson test" always rebuilds everything (that is one reason why we are not using it...). However, mtest2make can use this information to do a selective rebuild for the requested suite. Cc: Thomas Huth <thuth@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 34d4ff96aa..32f614b3dd 100644
--- a/meson.build
+++ b/meson.build
@@ -1103,7 +1103,7 @@ common_all = static_library('common',
feature_to_c = find_program('scripts/feature_to_c.sh')
-emulators = []
+emulators = {}
foreach target : target_dirs
config_target = config_target_mak[target]
target_name = config_target['TARGET_NAME']
@@ -1222,7 +1222,8 @@ foreach target : target_dirs
}]
endif
foreach exe: execs
- emulators += executable(exe['name'], exe['sources'],
+ emulators += {exe['name']:
+ executable(exe['name'], exe['sources'],
install: true,
c_args: c_args,
dependencies: arch_deps + deps + exe['dependencies'],
@@ -1231,6 +1232,7 @@ foreach target : target_dirs
link_depends: [block_syms, qemu_syms] + exe.get('link_depends', []),
link_args: link_args,
gui_app: exe['gui'])
+ }
if 'CONFIG_TRACE_SYSTEMTAP' in config_host
foreach stp: [
@@ -1276,7 +1278,6 @@ if xkbcommon.found()
dependencies: [qemuutil, xkbcommon], install: have_tools)
endif
-qemu_block_tools = []
if have_tools
qemu_img = executable('qemu-img', [files('qemu-img.c'), hxdep],
dependencies: [authz, block, crypto, io, qom, qemuutil], install: true)