summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-08-04 21:14:26 +0200
committerPaolo Bonzini2020-08-21 12:30:22 +0200
commitff219dca9ffa4c3417f8a00ef7ce3e9a15196eb0 (patch)
tree2fb0364c9b820b758dc54aa5e5da3221b589378c /meson.build
parentmeson: convert dump/ (diff)
downloadqemu-ff219dca9ffa4c3417f8a00ef7ce3e9a15196eb0.tar.gz
qemu-ff219dca9ffa4c3417f8a00ef7ce3e9a15196eb0.tar.xz
qemu-ff219dca9ffa4c3417f8a00ef7ce3e9a15196eb0.zip
meson: convert common QMP bits for qemu and qemu-storage-daemon
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6d5eb31dcf..9d1a530271 100644
--- a/meson.build
+++ b/meson.build
@@ -475,6 +475,7 @@ stub_ss = ss.source_set()
trace_ss = ss.source_set()
block_ss = ss.source_set()
blockdev_ss = ss.source_set()
+qmp_ss = ss.source_set()
common_ss = ss.source_set()
softmmu_ss = ss.source_set()
user_ss = ss.source_set()
@@ -655,6 +656,7 @@ softmmu_ss.add(when: ['CONFIG_FDT', fdt], if_true: [files('device_tree.c')])
common_ss.add(files('cpus-common.c'))
subdir('softmmu')
+subdir('monitor')
# needed for fuzzing binaries
subdir('tests/qtest/libqos')
@@ -704,6 +706,14 @@ block = declare_dependency(link_whole: [libblock],
link_args: '@block.syms',
dependencies: [crypto, io])
+qmp_ss = qmp_ss.apply(config_host, strict: false)
+libqmp = static_library('qmp', qmp_ss.sources() + genh,
+ dependencies: qmp_ss.dependencies(),
+ name_suffix: 'fa',
+ build_by_default: false)
+
+qmp = declare_dependency(link_whole: [libqmp])
+
foreach m : block_mods + softmmu_mods
shared_module(m.name(),
name_prefix: '',