summaryrefslogtreecommitdiffstats
path: root/meson_options.txt
diff options
context:
space:
mode:
authorRichard Henderson2020-09-13 21:19:25 +0200
committerRichard Henderson2020-10-03 11:22:47 +0200
commit8b18cdbfd6c7add5fb8dae5c81596c381fe6e237 (patch)
treecacce97e4b33e00419be35a74d23e54dd71fc1ae /meson_options.txt
parentMerge remote-tracking branch 'remotes/cohuck/tags/s390x-20201002' into staging (diff)
downloadqemu-8b18cdbfd6c7add5fb8dae5c81596c381fe6e237.tar.gz
qemu-8b18cdbfd6c7add5fb8dae5c81596c381fe6e237.tar.xz
qemu-8b18cdbfd6c7add5fb8dae5c81596c381fe6e237.zip
capstone: Convert Makefile bits to meson bits
There are better ways to do this, e.g. meson cmake subproject, but that requires cmake 3.7 and some of our CI environments only provide cmake 3.5. Nor can we add a meson.build file to capstone/, because the git submodule would then always report "untracked files". Fixing that would require creating our own branch on the qemu git mirror, at which point we could just as easily create a native meson subproject. Instead, build the library via the main meson.build. This improves the current state of affairs in that we will re-link the qemu executables against a changed libcapstone.a, which we wouldn't do before-hand. In addition, the use of the configuration header file instead of command-line -DEFINES means that we will rebuild the capstone objects with changes to meson.build. Acked-by: Paolo Bonzini <pbonzini@redhat.com> Reviewed-by: Alex Bennée <alex.bennee@linaro.org> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 46ea1d889a..a1228d29a9 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -31,3 +31,7 @@ option('vnc_sasl', type : 'feature', value : 'auto',
description: 'SASL authentication for VNC server')
option('xkbcommon', type : 'feature', value : 'auto',
description: 'xkbcommon support')
+
+option('capstone', type: 'combo', value: 'auto',
+ choices: ['disabled', 'enabled', 'auto', 'system', 'internal'],
+ description: 'Whether and how to find the capstone library')