summaryrefslogtreecommitdiffstats
path: root/net/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-22 21:47:50 +0200
committerPaolo Bonzini2020-08-21 12:30:23 +0200
commitcdaf07228cf42d708fe24371a68cec022841e018 (patch)
tree314dea957075960791922c9749c680fcbc86e88a /net/meson.build
parentmeson: convert migration directory to Meson (diff)
downloadqemu-cdaf07228cf42d708fe24371a68cec022841e018.tar.gz
qemu-cdaf07228cf42d708fe24371a68cec022841e018.tar.xz
qemu-cdaf07228cf42d708fe24371a68cec022841e018.zip
meson: convert net directory to Meson
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'net/meson.build')
-rw-r--r--net/meson.build40
1 files changed, 40 insertions, 0 deletions
diff --git a/net/meson.build b/net/meson.build
new file mode 100644
index 0000000000..6c2ec47dd5
--- /dev/null
+++ b/net/meson.build
@@ -0,0 +1,40 @@
+softmmu_ss.add(files(
+ 'announce.c',
+ 'checksum.c',
+ 'colo-compare.c',
+ 'colo.c',
+ 'dump.c',
+ 'eth.c',
+ 'filter-buffer.c',
+ 'filter-mirror.c',
+ 'filter-replay.c',
+ 'filter-rewriter.c',
+ 'filter.c',
+ 'hub.c',
+ 'net.c',
+ 'queue.c',
+ 'socket.c',
+ 'util.c',
+))
+
+softmmu_ss.add(when: 'CONFIG_L2TPV3', if_true: files('l2tpv3.c'))
+softmmu_ss.add(when: ['CONFIG_SLIRP', slirp], if_true: files('slirp.c'))
+softmmu_ss.add(when: ['CONFIG_VDE', vde], if_true: files('vde.c'))
+softmmu_ss.add(when: 'CONFIG_NETMAP', if_true: files('netmap.c'))
+vhost_user_ss = ss.source_set()
+vhost_user_ss.add(when: 'CONFIG_VIRTIO_NET', if_true: files('vhost-user.c'), if_false: files('vhost-user-stub.c'))
+softmmu_ss.add_all(when: 'CONFIG_VHOST_NET_USER', if_true: vhost_user_ss)
+softmmu_ss.add(when: 'CONFIG_ALL', if_true: files('vhost-user-stub.c'))
+
+softmmu_ss.add(when: 'CONFIG_LINUX', if_true: files('tap-linux.c'))
+softmmu_ss.add(when: 'CONFIG_BSD', if_true: files('tap-bsd.c'))
+softmmu_ss.add(when: 'CONFIG_SOLARIS', if_true: files('tap-solaris.c'))
+tap_posix = ['tap.c']
+if not config_host.has_key('CONFIG_LINUX') and not config_host.has_key('CONFIG_BSD') and not config_host.has_key('CONFIG_SOLARIS')
+ tap_posix += 'tap-stub.c'
+endif
+softmmu_ss.add(when: 'CONFIG_POSIX', if_true: files(tap_posix))
+softmmu_ss.add(when: 'CONFIG_WIN32', if_true: files('tap-win32.c'))
+softmmu_ss.add(when: 'CONFIG_VHOST_NET_VDPA', if_true: files('vhost-vdpa.c'))
+
+subdir('can')