summaryrefslogtreecommitdiffstats
path: root/qapi/meson.build
diff options
context:
space:
mode:
authorDaniel P. Berrangé2021-10-08 16:09:00 +0200
committerDaniel P. Berrangé2021-11-02 16:55:13 +0100
commitf9429c6790ce0c9f737d318eeff5c4a24f641ec2 (patch)
tree418362075b55a83a80e77fea1180434379b6f82d /qapi/meson.build
parentdocs/devel: update error handling guidance for HMP commands (diff)
downloadqemu-f9429c6790ce0c9f737d318eeff5c4a24f641ec2.tar.gz
qemu-f9429c6790ce0c9f737d318eeff5c4a24f641ec2.tar.xz
qemu-f9429c6790ce0c9f737d318eeff5c4a24f641ec2.zip
monitor: introduce HumanReadableText and HMP support
This provides a foundation on which to convert simple HMP commands to use QMP. The QMP implementation will generate formatted text targeted for human consumption, returning it in the HumanReadableText data type. The HMP command handler will simply print out the formatted string within the HumanReadableText data type. Since this will be an entirely formulaic action in the case of HMP commands taking no arguments, a custom command handler is provided. Thus instead of registering a 'cmd' callback for the HMP command, a 'cmd_info_hrt' callback is provided, which will simply be a pointer to the QMP implementation. Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Tested-by: Philippe Mathieu-Daudé <philmd@redhat.com> Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'qapi/meson.build')
-rw-r--r--qapi/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/qapi/meson.build b/qapi/meson.build
index c356a385e3..c0c49c15e4 100644
--- a/qapi/meson.build
+++ b/qapi/meson.build
@@ -10,6 +10,9 @@ util_ss.add(files(
'string-input-visitor.c',
'string-output-visitor.c',
))
+if have_system
+ util_ss.add(files('qapi-type-helpers.c'))
+endif
if have_system or have_tools
util_ss.add(files(
'qmp-dispatch.c',