summaryrefslogtreecommitdiffstats
path: root/target/arm/meson.build
diff options
context:
space:
mode:
authorPeter Maydell2021-04-30 15:27:40 +0200
committerPeter Maydell2021-05-10 14:24:09 +0200
commit4800b852b8099187d2186c213626c298a60b775c (patch)
tree0ec029469518cdb5d0673df2650625784a896516 /target/arm/meson.build
parenttarget/arm: Make functions used by translate-neon global (diff)
downloadqemu-4800b852b8099187d2186c213626c298a60b775c.tar.gz
qemu-4800b852b8099187d2186c213626c298a60b775c.tar.xz
qemu-4800b852b8099187d2186c213626c298a60b775c.zip
target/arm: Make translate-neon.c.inc its own compilation unit
Switch translate-neon.c.inc from being #included into translate.c to being its own compilation unit. Signed-off-by: Peter Maydell <peter.maydell@linaro.org> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-id: 20210430132740.10391-14-peter.maydell@linaro.org
Diffstat (limited to 'target/arm/meson.build')
-rw-r--r--target/arm/meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/arm/meson.build b/target/arm/meson.build
index f6360f33f1..5bfaf43b50 100644
--- a/target/arm/meson.build
+++ b/target/arm/meson.build
@@ -1,8 +1,8 @@
gen = [
decodetree.process('sve.decode', extra_args: '--decode=disas_sve'),
- decodetree.process('neon-shared.decode', extra_args: '--static-decode=disas_neon_shared'),
- decodetree.process('neon-dp.decode', extra_args: '--static-decode=disas_neon_dp'),
- decodetree.process('neon-ls.decode', extra_args: '--static-decode=disas_neon_ls'),
+ decodetree.process('neon-shared.decode', extra_args: '--decode=disas_neon_shared'),
+ decodetree.process('neon-dp.decode', extra_args: '--decode=disas_neon_dp'),
+ decodetree.process('neon-ls.decode', extra_args: '--decode=disas_neon_ls'),
decodetree.process('vfp.decode', extra_args: '--decode=disas_vfp'),
decodetree.process('vfp-uncond.decode', extra_args: '--decode=disas_vfp_uncond'),
decodetree.process('m-nocp.decode', extra_args: '--decode=disas_m_nocp'),
@@ -27,6 +27,7 @@ arm_ss.add(files(
'tlb_helper.c',
'translate.c',
'translate-m-nocp.c',
+ 'translate-neon.c',
'translate-vfp.c',
'vec_helper.c',
'vfp_helper.c',