summaryrefslogtreecommitdiffstats
path: root/target/arm/meson.build
diff options
context:
space:
mode:
authorPeter Maydell2021-06-14 17:09:20 +0200
committerPeter Maydell2021-06-16 15:33:52 +0200
commit6390eed45cab462320ceb4cbfc2cbd1c1552ed00 (patch)
treeb47b4b8b373cb717425d392ac63627f7ce5dcf63 /target/arm/meson.build
parenttarget/arm: Implement MVE LETP insn (diff)
downloadqemu-6390eed45cab462320ceb4cbfc2cbd1c1552ed00.tar.gz
qemu-6390eed45cab462320ceb4cbfc2cbd1c1552ed00.tar.xz
qemu-6390eed45cab462320ceb4cbfc2cbd1c1552ed00.zip
target/arm: Add framework for MVE decode
Add the framework for decoding MVE insns, with the necessary new files and the meson.build rules, but no actual content yet. Signed-off-by: Peter Maydell <peter.maydell@linaro.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-id: 20210614151007.4545-11-peter.maydell@linaro.org
Diffstat (limited to 'target/arm/meson.build')
-rw-r--r--target/arm/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/arm/meson.build b/target/arm/meson.build
index 5bfaf43b50..2b50be3f86 100644
--- a/target/arm/meson.build
+++ b/target/arm/meson.build
@@ -6,6 +6,7 @@ gen = [
decodetree.process('vfp.decode', extra_args: '--decode=disas_vfp'),
decodetree.process('vfp-uncond.decode', extra_args: '--decode=disas_vfp_uncond'),
decodetree.process('m-nocp.decode', extra_args: '--decode=disas_m_nocp'),
+ decodetree.process('mve.decode', extra_args: '--decode=disas_mve'),
decodetree.process('a32.decode', extra_args: '--static-decode=disas_a32'),
decodetree.process('a32-uncond.decode', extra_args: '--static-decode=disas_a32_uncond'),
decodetree.process('t32.decode', extra_args: '--static-decode=disas_t32'),
@@ -27,6 +28,7 @@ arm_ss.add(files(
'tlb_helper.c',
'translate.c',
'translate-m-nocp.c',
+ 'translate-mve.c',
'translate-neon.c',
'translate-vfp.c',
'vec_helper.c',