summaryrefslogtreecommitdiffstats
path: root/target/arm/meson.build
diff options
context:
space:
mode:
authorPeter Maydell2021-04-30 15:27:31 +0200
committerPeter Maydell2021-05-10 14:24:09 +0200
commit9a5071abbce614c52d0e72bdbd688cd4e2a9ee46 (patch)
tree4c69898d76195bbd6d000386fabf16623c90b30f /target/arm/meson.build
parenttarget/arm: Make functions used by m-nocp global (diff)
downloadqemu-9a5071abbce614c52d0e72bdbd688cd4e2a9ee46.tar.gz
qemu-9a5071abbce614c52d0e72bdbd688cd4e2a9ee46.tar.xz
qemu-9a5071abbce614c52d0e72bdbd688cd4e2a9ee46.zip
target/arm: Split m-nocp trans functions into their own file
Currently the trans functions for m-nocp.decode all live in translate-vfp.inc.c; move them out into their own translation unit, translate-m-nocp.c. The trans_* functions here are pure code motion with no changes. Signed-off-by: Peter Maydell <peter.maydell@linaro.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-id: 20210430132740.10391-5-peter.maydell@linaro.org
Diffstat (limited to 'target/arm/meson.build')
-rw-r--r--target/arm/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/arm/meson.build b/target/arm/meson.build
index 15b936c101..bbee1325bc 100644
--- a/target/arm/meson.build
+++ b/target/arm/meson.build
@@ -5,7 +5,7 @@ gen = [
decodetree.process('neon-ls.decode', extra_args: '--static-decode=disas_neon_ls'),
decodetree.process('vfp.decode', extra_args: '--static-decode=disas_vfp'),
decodetree.process('vfp-uncond.decode', extra_args: '--static-decode=disas_vfp_uncond'),
- decodetree.process('m-nocp.decode', extra_args: '--static-decode=disas_m_nocp'),
+ decodetree.process('m-nocp.decode', extra_args: '--decode=disas_m_nocp'),
decodetree.process('a32.decode', extra_args: '--static-decode=disas_a32'),
decodetree.process('a32-uncond.decode', extra_args: '--static-decode=disas_a32_uncond'),
decodetree.process('t32.decode', extra_args: '--static-decode=disas_t32'),
@@ -26,6 +26,7 @@ arm_ss.add(files(
'op_helper.c',
'tlb_helper.c',
'translate.c',
+ 'translate-m-nocp.c',
'vec_helper.c',
'vfp_helper.c',
'cpu_tcg.c',