summaryrefslogtreecommitdiffstats
path: root/target/loongarch/meson.build
diff options
context:
space:
mode:
authorXiaojuan Yang2022-06-06 14:43:16 +0200
committerRichard Henderson2022-06-06 20:09:03 +0200
commitf84a2aacf5d1679b1d1cceabb6006e02864232f3 (patch)
tree7ab99d30271e045fd93932c599aa8d6901aa54ae /target/loongarch/meson.build
parenttarget/loongarch: Add LoongArch CSR instruction (diff)
downloadqemu-f84a2aacf5d1679b1d1cceabb6006e02864232f3.tar.gz
qemu-f84a2aacf5d1679b1d1cceabb6006e02864232f3.tar.xz
qemu-f84a2aacf5d1679b1d1cceabb6006e02864232f3.zip
target/loongarch: Add LoongArch IOCSR instruction
This includes: - IOCSR{RD/WR}.{B/H/W/D} Signed-off-by: Xiaojuan Yang <yangxiaojuan@loongson.cn> Signed-off-by: Song Gao <gaosong@loongson.cn> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20220606124333.2060567-27-yangxiaojuan@loongson.cn> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'target/loongarch/meson.build')
-rw-r--r--target/loongarch/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/loongarch/meson.build b/target/loongarch/meson.build
index d11829a6cc..74e5f3b2a7 100644
--- a/target/loongarch/meson.build
+++ b/target/loongarch/meson.build
@@ -20,6 +20,7 @@ loongarch_softmmu_ss.add(files(
'tlb_helper.c',
'constant_timer.c',
'csr_helper.c',
+ 'iocsr_helper.c',
))
loongarch_ss.add_all(when: 'CONFIG_TCG', if_true: [loongarch_tcg_ss])