summaryrefslogtreecommitdiffstats
path: root/target/mips/tcg/user/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2021-04-18 15:16:06 +0200
committerPhilippe Mathieu-Daudé2021-05-02 16:49:34 +0200
commit0a31c16c9ce2639c8706b9f863724ba42a46f121 (patch)
tree168fd4309d419652bc2b16ee1c9219f16ef280e0 /target/mips/tcg/user/meson.build
parenttarget/mips: Introduce tcg-internal.h for TCG specific declarations (diff)
downloadqemu-0a31c16c9ce2639c8706b9f863724ba42a46f121.tar.gz
qemu-0a31c16c9ce2639c8706b9f863724ba42a46f121.tar.xz
qemu-0a31c16c9ce2639c8706b9f863724ba42a46f121.zip
target/mips: Add simple user-mode mips_cpu_do_interrupt()
The #ifdef'ry hides that the user-mode implementation of mips_cpu_do_interrupt() simply sets exception_index = EXCP_NONE. Add this simple implementation to tcg/user/tlb_helper.c, and the corresponding Meson machinery to build this file when user emulation is configured. Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20210428170410.479308-14-f4bug@amsat.org>
Diffstat (limited to 'target/mips/tcg/user/meson.build')
-rw-r--r--target/mips/tcg/user/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/mips/tcg/user/meson.build b/target/mips/tcg/user/meson.build
new file mode 100644
index 0000000000..79badcd321
--- /dev/null
+++ b/target/mips/tcg/user/meson.build
@@ -0,0 +1,3 @@
+mips_user_ss.add(files(
+ 'tlb_helper.c',
+))