summaryrefslogtreecommitdiffstats
path: root/target/s390x/meson.build
diff options
context:
space:
mode:
authorCho, Yu-Chen2021-07-07 12:53:11 +0200
committerCornelia Huck2021-07-07 14:01:52 +0200
commit33f6a7d66f9e87368ae43fec4adf0d04d9ded0bd (patch)
treea107a1bd2ddf5097f18650e287f27958b3ad59e3 /target/s390x/meson.build
parents390x/tcg: Fix m5 vs. m4 field for VECTOR MULTIPLY SUM LOGICAL (diff)
downloadqemu-33f6a7d66f9e87368ae43fec4adf0d04d9ded0bd.tar.gz
qemu-33f6a7d66f9e87368ae43fec4adf0d04d9ded0bd.tar.xz
qemu-33f6a7d66f9e87368ae43fec4adf0d04d9ded0bd.zip
target/s390x: meson: add target_user_arch
the lack of target_user_arch makes it hard to fully leverage the build system in order to separate user code from sysemu code. Provide it, so that we can avoid the proliferation of #ifdef in target code. Signed-off-by: Claudio Fontana <cfontana@suse.de> Signed-off-by: Cho, Yu-Chen <acho@suse.com> Acked-by: Cornelia Huck <cohuck@redhat.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Reviewed-by: Thomas Huth <thuth@redhat.com> Message-Id: <20210707105324.23400-2-acho@suse.com> Signed-off-by: Cornelia Huck <cohuck@redhat.com>
Diffstat (limited to 'target/s390x/meson.build')
-rw-r--r--target/s390x/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/s390x/meson.build b/target/s390x/meson.build
index c42eadb7d2..1219f64112 100644
--- a/target/s390x/meson.build
+++ b/target/s390x/meson.build
@@ -58,5 +58,8 @@ if host_machine.cpu_family() == 's390x' and cc.has_link_argument('-Wl,--s390-pgs
if_true: declare_dependency(link_args: ['-Wl,--s390-pgste']))
endif
+s390x_user_ss = ss.source_set()
+
target_arch += {'s390x': s390x_ss}
target_softmmu_arch += {'s390x': s390x_softmmu_ss}
+target_user_arch += {'s390x': s390x_user_ss}