summaryrefslogtreecommitdiffstats
path: root/target/s390x/meson.build
diff options
context:
space:
mode:
authorCho, Yu-Chen2021-07-07 12:53:23 +0200
committerCornelia Huck2021-07-07 14:01:59 +0200
commit67043607d17cf62f4ae8110151c44fb73295e66f (patch)
tree99a58795af7a37f2103c0d179ec6508897a7b9b2 /target/s390x/meson.build
parenttarget/s390x: remove kvm-stub.c (diff)
downloadqemu-67043607d17cf62f4ae8110151c44fb73295e66f.tar.gz
qemu-67043607d17cf62f4ae8110151c44fb73295e66f.tar.xz
qemu-67043607d17cf62f4ae8110151c44fb73295e66f.zip
target/s390x: move kvm files into kvm/
move kvm files into kvm/ After the reshuffling, update MAINTAINERS accordingly. Make use of the new directory: target/s390x/kvm/ Signed-off-by: Claudio Fontana <cfontana@suse.de> Signed-off-by: Cho, Yu-Chen <acho@suse.com> Reviewed-by: Cornelia Huck <cohuck@redhat.com> Reviewed-by: Thomas Huth <thuth@redhat.com> Message-Id: <20210707105324.23400-14-acho@suse.com> Signed-off-by: Cornelia Huck <cohuck@redhat.com>
Diffstat (limited to 'target/s390x/meson.build')
-rw-r--r--target/s390x/meson.build16
1 files changed, 1 insertions, 15 deletions
diff --git a/target/s390x/meson.build b/target/s390x/meson.build
index 6c8e03b8fb..ec73bed524 100644
--- a/target/s390x/meson.build
+++ b/target/s390x/meson.build
@@ -8,8 +8,6 @@ s390x_ss.add(files(
'cpu-dump.c',
))
-s390x_ss.add(when: 'CONFIG_KVM', if_true: files('kvm.c'))
-
gen_features = executable('gen-features', 'gen-features.c', native: true,
build_by_default: false)
@@ -32,22 +30,10 @@ s390x_softmmu_ss.add(files(
'cpu-sysemu.c',
))
-# Newer kernels on s390 check for an S390_PGSTE program header and
-# enable the pgste page table extensions in that case. This makes
-# the vm.allocate_pgste sysctl unnecessary. We enable this program
-# header if
-# - we build on s390x
-# - we build the system emulation for s390x (qemu-system-s390x)
-# - KVM is enabled
-# - the linker supports --s390-pgste
-if host_machine.cpu_family() == 's390x' and cc.has_link_argument('-Wl,--s390-pgste')
- s390x_softmmu_ss.add(when: 'CONFIG_KVM',
- if_true: declare_dependency(link_args: ['-Wl,--s390-pgste']))
-endif
-
s390x_user_ss = ss.source_set()
subdir('tcg')
+subdir('kvm')
target_arch += {'s390x': s390x_ss}
target_softmmu_arch += {'s390x': s390x_softmmu_ss}