summaryrefslogtreecommitdiffstats
path: root/target/xtensa/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-08-07 12:10:23 +0200
committerPaolo Bonzini2020-08-21 12:30:35 +0200
commitabff1abfe8113a989215ed33c48839a827e531f1 (patch)
treefb31d57aff267871822d237052c264788664047e /target/xtensa/meson.build
parentmeson: convert hw/arch* (diff)
downloadqemu-abff1abfe8113a989215ed33c48839a827e531f1.tar.gz
qemu-abff1abfe8113a989215ed33c48839a827e531f1.tar.xz
qemu-abff1abfe8113a989215ed33c48839a827e531f1.zip
meson: target
Similar to hw_arch, each architecture defines two sourceset which are placed in dictionaries target_arch and target_softmmu_arch. These are then picked up from there when building the per-emulator static_library. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'target/xtensa/meson.build')
-rw-r--r--target/xtensa/meson.build30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/xtensa/meson.build b/target/xtensa/meson.build
new file mode 100644
index 0000000000..27e453e1d1
--- /dev/null
+++ b/target/xtensa/meson.build
@@ -0,0 +1,30 @@
+xtensa_ss = ss.source_set()
+xtensa_ss.add(files(
+ 'core-dc232b.c',
+ 'core-dc233c.c',
+ 'core-de212.c',
+ 'core-fsf.c',
+ 'core-sample_controller.c',
+ 'core-test_kc705_be.c',
+ 'core-test_mmuhifi_c3.c',
+ 'cpu.c',
+ 'exc_helper.c',
+ 'fpu_helper.c',
+ 'gdbstub.c',
+ 'helper.c',
+ 'op_helper.c',
+ 'translate.c',
+ 'win_helper.c',
+ 'xtensa-isa.c',
+))
+
+xtensa_softmmu_ss = ss.source_set()
+xtensa_softmmu_ss.add(files(
+ 'dbg_helper.c',
+ 'mmu_helper.c',
+ 'monitor.c',
+ 'xtensa-semi.c',
+))
+
+target_arch += {'xtensa': xtensa_ss}
+target_softmmu_arch += {'xtensa': xtensa_softmmu_ss}