summaryrefslogtreecommitdiffstats
path: root/tests/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-12-18 16:39:43 +0100
committerPaolo Bonzini2022-02-16 15:01:33 +0100
commit43a363ae35f4a04bfb86e0ad033d33ef83514597 (patch)
tree682658453dd11862be4c1c5e08ec557baccdee79 /tests/meson.build
parenttests/qemu-iotests/testrunner: Print diff to stderr in TAP mode (diff)
downloadqemu-43a363ae35f4a04bfb86e0ad033d33ef83514597.tar.gz
qemu-43a363ae35f4a04bfb86e0ad033d33ef83514597.tar.xz
qemu-43a363ae35f4a04bfb86e0ad033d33ef83514597.zip
meson: use .allowed() method for features
The method is now in 0.59, using it simplifies some boolean conditions. The other new methods .require() and .disable_auto_if() can be used too, but introducing them is not just a matter of search-and-replace. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 079c8f3727..1d05109eb4 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -85,7 +85,7 @@ if 'CONFIG_TCG' in config_all
subdir('fp')
endif
-if not get_option('tcg').disabled()
+if get_option('tcg').allowed()
if 'CONFIG_PLUGIN' in config_host
subdir('plugin')
endif