summaryrefslogtreecommitdiffstats
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
authorPeter Maydell2022-02-23 10:25:05 +0100
committerPeter Maydell2022-02-23 10:25:05 +0100
commit4aa2e497a98bafe962e72997f67a369e4b52d9c1 (patch)
treea688eb9c357022c35eab15ad1dc155b413d581e8 /tests/unit/meson.build
parentMerge remote-tracking branch 'remotes/lvivier-gitlab/tags/trivial-branch-for-... (diff)
parentdocs: expand firmware descriptor to allow flash without NVRAM (diff)
downloadqemu-4aa2e497a98bafe962e72997f67a369e4b52d9c1.tar.gz
qemu-4aa2e497a98bafe962e72997f67a369e4b52d9c1.tar.xz
qemu-4aa2e497a98bafe962e72997f67a369e4b52d9c1.zip
Merge remote-tracking branch 'remotes/berrange-gitlab/tags/misc-next-pull-request' into staging
This misc series of changes: - Improves documentation of SSH fingerprint checking - Fixes SHA256 fingerprints with non-blockdev usage - Blocks the clone3, setns, unshare & execveat syscalls with seccomp - Blocks process spawning via clone syscall, but allows threads, with seccomp - Takes over seccomp maintainer role - Expands firmware descriptor spec to allow flash without NVRAM # gpg: Signature made Thu 17 Feb 2022 11:57:13 GMT # gpg: using RSA key DAF3A6FDB26B62912D0E8E3FBE86EBB415104FDF # gpg: Good signature from "Daniel P. Berrange <dan@berrange.com>" [full] # gpg: aka "Daniel P. Berrange <berrange@redhat.com>" [full] # Primary key fingerprint: DAF3 A6FD B26B 6291 2D0E 8E3F BE86 EBB4 1510 4FDF * remotes/berrange-gitlab/tags/misc-next-pull-request: docs: expand firmware descriptor to allow flash without NVRAM MAINTAINERS: take over seccomp from Eduardo Otubo seccomp: block setns, unshare and execveat syscalls seccomp: block use of clone3 syscall seccomp: fix blocking of process spawning seccomp: add unit test for seccomp filtering seccomp: allow action to be customized per syscall block: print the server key type and fingerprint on failure block: support sha256 fingerprint with pre-blockdev options block: better document SSH host key fingerprint checking Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
index 3a51759ebc..96b295263e 100644
--- a/tests/unit/meson.build
+++ b/tests/unit/meson.build
@@ -53,6 +53,10 @@ if have_system or have_tools
tests += {
'test-qmp-event': [testqapi],
}
+
+ if seccomp.found()
+ tests += {'test-seccomp': ['../../softmmu/qemu-seccomp.c', seccomp]}
+ endif
endif
if have_block