summaryrefslogtreecommitdiffstats
path: root/tests/unit/meson.build
diff options
context:
space:
mode:
authorLei He2022-05-25 11:01:13 +0200
committerDaniel P. Berrangé2022-05-26 12:41:49 +0200
commit99d423f10c636c39405924e68584f50f78a0bb8c (patch)
tree4f7f1eeca23e0bf107f1c1e3b16132c3751423a6 /tests/unit/meson.build
parentcrypto: Introduce akcipher crypto class (diff)
downloadqemu-99d423f10c636c39405924e68584f50f78a0bb8c.tar.gz
qemu-99d423f10c636c39405924e68584f50f78a0bb8c.tar.xz
qemu-99d423f10c636c39405924e68584f50f78a0bb8c.zip
crypto: add ASN.1 DER decoder
Add an ANS.1 DER decoder which is used to parse asymmetric cipher keys Signed-off-by: zhenwei pi <pizhenwei@bytedance.com> Signed-off-by: lei he <helei.sig11@bytedance.com> Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
Diffstat (limited to 'tests/unit/meson.build')
-rw-r--r--tests/unit/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/unit/meson.build b/tests/unit/meson.build
index 264f2bc0c8..5a7993e56c 100644
--- a/tests/unit/meson.build
+++ b/tests/unit/meson.build
@@ -78,6 +78,7 @@ if have_block
'test-crypto-hmac': [crypto],
'test-crypto-cipher': [crypto],
'test-crypto-secret': [crypto, keyutils],
+ 'test-crypto-der': [crypto],
'test-authz-simple': [authz],
'test-authz-list': [authz],
'test-authz-listfile': [authz],