summaryrefslogtreecommitdiffstats
path: root/hw/lm32/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/lm32/meson.build')
-rw-r--r--hw/lm32/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/hw/lm32/meson.build b/hw/lm32/meson.build
new file mode 100644
index 0000000000..8caf0a727f
--- /dev/null
+++ b/hw/lm32/meson.build
@@ -0,0 +1,6 @@
+lm32_ss = ss.source_set()
+# LM32 boards
+lm32_ss.add(when: 'CONFIG_LM32', if_true: files('lm32_boards.c'))
+lm32_ss.add(when: 'CONFIG_MILKYMIST', if_true: files('milkymist.c'))
+
+hw_arch += {'lm32': lm32_ss}