summaryrefslogtreecommitdiffstats
path: root/hw/mem/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/mem/meson.build')
-rw-r--r--hw/mem/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/hw/mem/meson.build b/hw/mem/meson.build
new file mode 100644
index 0000000000..ba424622bb
--- /dev/null
+++ b/hw/mem/meson.build
@@ -0,0 +1,6 @@
+mem_ss = ss.source_set()
+mem_ss.add(files('memory-device.c'))
+mem_ss.add(when: 'CONFIG_DIMM', if_true: files('pc-dimm.c'))
+mem_ss.add(when: 'CONFIG_NVDIMM', if_true: files('nvdimm.c'))
+
+softmmu_ss.add_all(when: 'CONFIG_MEM_DEVICE', if_true: mem_ss)