summaryrefslogtreecommitdiffstats
path: root/hw/pci/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/pci/meson.build')
-rw-r--r--hw/pci/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/hw/pci/meson.build b/hw/pci/meson.build
new file mode 100644
index 0000000000..5c4bbac817
--- /dev/null
+++ b/hw/pci/meson.build
@@ -0,0 +1,19 @@
+pci_ss = ss.source_set()
+pci_ss.add(files(
+ 'msi.c',
+ 'msix.c',
+ 'pci.c',
+ 'pci_bridge.c',
+ 'pci_host.c',
+ 'shpc.c',
+ 'slotid_cap.c'
+))
+# The functions in these modules can be used by devices too. Since we
+# allow plugging PCIe devices into PCI buses, include them even if
+# CONFIG_PCI_EXPRESS=n.
+pci_ss.add(files('pcie.c', 'pcie_aer.c'))
+softmmu_ss.add(when: 'CONFIG_PCI_EXPRESS', if_true: files('pcie_port.c', 'pcie_host.c'))
+softmmu_ss.add_all(when: 'CONFIG_PCI', if_true: pci_ss)
+
+softmmu_ss.add(when: 'CONFIG_PCI', if_false: files('pci-stub.c'))
+softmmu_ss.add(when: 'CONFIG_ALL', if_true: files('pci-stub.c'))