summaryrefslogtreecommitdiffstats
path: root/target/mips/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/mips/meson.build')
-rw-r--r--target/mips/meson.build21
1 files changed, 18 insertions, 3 deletions
diff --git a/target/mips/meson.build b/target/mips/meson.build
index 4179395a8e..9741545440 100644
--- a/target/mips/meson.build
+++ b/target/mips/meson.build
@@ -1,25 +1,40 @@
+gen = [
+ decodetree.process('mips32r6.decode', extra_args: '--static-decode=decode_mips32r6'),
+ decodetree.process('mips64r6.decode', extra_args: '--static-decode=decode_mips64r6'),
+ decodetree.process('msa32.decode', extra_args: '--static-decode=decode_msa32'),
+ decodetree.process('msa64.decode', extra_args: '--static-decode=decode_msa64'),
+]
+
mips_ss = ss.source_set()
+mips_ss.add(gen)
mips_ss.add(files(
'cpu.c',
+ 'gdbstub.c',
+))
+mips_ss.add(when: 'CONFIG_TCG', if_true: files(
'dsp_helper.c',
'fpu_helper.c',
- 'gdbstub.c',
- 'helper.c',
'lmmi_helper.c',
'msa_helper.c',
+ 'msa_translate.c',
'op_helper.c',
+ 'rel6_translate.c',
+ 'tlb_helper.c',
'translate.c',
+ 'translate_addr_const.c',
))
mips_ss.add(when: 'CONFIG_KVM', if_true: files('kvm.c'))
mips_softmmu_ss = ss.source_set()
mips_softmmu_ss.add(files(
'addr.c',
- 'cp0_helper.c',
'cp0_timer.c',
'machine.c',
'mips-semi.c',
))
+mips_softmmu_ss.add(when: 'CONFIG_TCG', if_true: files(
+ 'cp0_helper.c',
+))
target_arch += {'mips': mips_ss}
target_softmmu_arch += {'mips': mips_softmmu_ss}