summaryrefslogtreecommitdiffstats
path: root/target/sh4/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/sh4/meson.build')
-rw-r--r--target/sh4/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/sh4/meson.build b/target/sh4/meson.build
new file mode 100644
index 0000000000..56a57576da
--- /dev/null
+++ b/target/sh4/meson.build
@@ -0,0 +1,14 @@
+sh4_ss = ss.source_set()
+sh4_ss.add(files(
+ 'cpu.c',
+ 'gdbstub.c',
+ 'helper.c',
+ 'op_helper.c',
+ 'translate.c',
+))
+
+sh4_softmmu_ss = ss.source_set()
+sh4_softmmu_ss.add(files('monitor.c'))
+
+target_arch += {'sh4': sh4_ss}
+target_softmmu_arch += {'sh4': sh4_softmmu_ss}