summaryrefslogtreecommitdiffstats
path: root/target/tricore/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/tricore/meson.build')
-rw-r--r--target/tricore/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/tricore/meson.build b/target/tricore/meson.build
new file mode 100644
index 0000000000..0ccc829517
--- /dev/null
+++ b/target/tricore/meson.build
@@ -0,0 +1,15 @@
+tricore_ss = ss.source_set()
+tricore_ss.add(files(
+ 'cpu.c',
+ 'fpu_helper.c',
+ 'helper.c',
+ 'op_helper.c',
+ 'translate.c',
+ 'gdbstub.c',
+))
+tricore_ss.add(zlib)
+
+tricore_softmmu_ss = ss.source_set()
+
+target_arch += {'tricore': tricore_ss}
+target_softmmu_arch += {'tricore': tricore_softmmu_ss}