summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsr2012-08-30 00:36:54 +0200
committersr2012-08-30 00:36:54 +0200
commit5b9b2174512d97399c68172bffe91cf928b1400a (patch)
treebf2cb9a7ae67cfe922fc7d2a6dcb432eaad4a2d9 /CMakeLists.txt
parentFix linebreak, add comment (diff)
downloaddnbd3-5b9b2174512d97399c68172bffe91cf928b1400a.tar.gz
dnbd3-5b9b2174512d97399c68172bffe91cf928b1400a.tar.xz
dnbd3-5b9b2174512d97399c68172bffe91cf928b1400a.zip
[SERVER] Set _FILE_OFFSET_BITS=64 so that images >4GiB will be handled properly on 32bit
[SERVER] Change IPC interface to be able to handle more than 1 request per connection [SERVER] Change IPC interface to use select() so it can handle multiple connections at the same time [SERVER] Re-Implement dnbd3_add_image() to work with image list [SERVER] Add lots of sanity/safety checks and error messages when loading/adding an image
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a959f66..3a68bce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,7 @@ SET(CMAKE_CXX_FLAGS_DEBUG "-O0 -g -Wall -Wno-unused-result -D_GNU_SOURCE -D_FILE
SET(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wno-unused-result -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64" )
ADD_DEFINITIONS(-DIPC_TCP)
+ADD_DEFINITIONS(-D_FILE_OFFSET_BITS=64)
FIND_PACKAGE(Threads REQUIRED)
FIND_PACKAGE(PkgConfig REQUIRED)