summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2021-03-17 09:04:04 +0100
committerManuel Bentele2021-03-17 09:04:04 +0100
commit6a047088cb26248ec783713bb94925638aad8552 (patch)
tree2f4259161cacd3f9e50f99cc4fd7cb5600f4dd6b /CMakeLists.txt
parent[KERNEL] Enable assertions if CONFIG_DEBUG_DRIVER is set (diff)
downloaddnbd3-6a047088cb26248ec783713bb94925638aad8552.tar.gz
dnbd3-6a047088cb26248ec783713bb94925638aad8552.tar.xz
dnbd3-6a047088cb26248ec783713bb94925638aad8552.zip
[BUILD] Fix build issue if version information (Git tag) is missing
The software version for packaging purposes is consituted from the following rules: - If the version information (from Git tags or the embedded version header file) is available, the version number for the packaging is set to those found version information. - If there isn't any version information available (e.g. missing Git tags), the version number for the packaging is set to '0.0' to represent an unkown version number.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb4d5d1..bb613df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,7 +122,7 @@ endif(DNBD3_RELEASE_HARDEN AND CMAKE_BUILD_TYPE MATCHES "Release")
# define packaging if Release build is enabled
if(CMAKE_BUILD_TYPE MATCHES Release)
# get version source package or Git repository
- get_repository_version(REPOSITORY_VERSION ${INCLUDE_VERSION_HEADER} ${CMAKE_BUILD_TYPE} ${GIT_EXECUTABLE} ${CMAKE_SOURCE_DIR})
+ get_repository_version(REPOSITORY_VERSION REPOSITORY_BRANCH ${INCLUDE_VERSION_HEADER} ${CMAKE_BUILD_TYPE} ${GIT_EXECUTABLE} ${CMAKE_SOURCE_DIR})
# define project version
if(KernelHeaders_VERSION)