summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Rettberg2017-10-26 23:38:02 +0200
committerSimon Rettberg2017-10-26 23:38:02 +0200
commit725dd45757b2fc60d5b5b2baecf89c4fbdeca129 (patch)
tree2f516c0d499872f7fef090521f3108cc6c150296 /CMakeLists.txt
parent[SERVER] net: Simplify check for HTTP (diff)
downloaddnbd3-725dd45757b2fc60d5b5b2baecf89c4fbdeca129.tar.gz
dnbd3-725dd45757b2fc60d5b5b2baecf89c4fbdeca129.tar.xz
dnbd3-725dd45757b2fc60d5b5b2baecf89c4fbdeca129.zip
[SERVER] Use picohttpparser from h2o
Simple and lean interface, no bloat, noice. Slighly modified to use a simple string struct for passing around strings that are not null terminated, instead of separate char* and length.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6f35c0a..d738bd1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -141,7 +141,7 @@ ENDIF()
if(BUILD_SERVER)
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${JANSSON_INCLUDE_DIR})
- FILE(GLOB SERVER_SRCS src/server/*.c src/shared/*.c)
+ FILE(GLOB SERVER_SRCS src/server/*.c src/shared/*.c src/server/picohttpparser/*.c)
ADD_EXECUTABLE(dnbd3-server ${SERVER_SRCS})
TARGET_LINK_LIBRARIES(dnbd3-server ${CMAKE_THREAD_LIBS_INIT} ${JANSSON_LIBRARIES})
if(UNIX AND NOT APPLE)