summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2021-03-02 11:32:56 +0100
committerManuel Bentele2021-03-02 11:32:56 +0100
commitb0f6b66d4e7e2211929210f95089dfb47f5d23be (patch)
tree70489e8e3db7f2cc577773248617fe38f97e7964 /CMakeLists.txt
parent[DOC] replace tabs with whitespaces (diff)
downloaddnbd3-b0f6b66d4e7e2211929210f95089dfb47f5d23be.tar.gz
dnbd3-b0f6b66d4e7e2211929210f95089dfb47f5d23be.tar.xz
dnbd3-b0f6b66d4e7e2211929210f95089dfb47f5d23be.zip
[BUILD] Add build support for Github actions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65b9ebb..7c104a9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -89,7 +89,7 @@ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3 -DNDEBUG")
if(DNBD3_RELEASE_HARDEN AND CMAKE_BUILD_TYPE MATCHES "Release")
# harden builds with specific C flags
- set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -D_FORTIFY_SOURCE=2 -fstack-protector-all -fstack-clash-protection -mfunction-return=thunk -mindirect-branch=thunk")
+ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -D_FORTIFY_SOURCE=2 -fstack-protector-all -fstack-clash-protection")
# set specific hardened linker flags
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,-z,relro,-z,now,-z,defs -pie")
# print status message of configuration