summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-10-22 19:00:52 +0200
committerManuel Bentele2020-10-22 19:00:52 +0200
commitb5445d3fae2fca61ed036a4e88f061903965db7a (patch)
treebf4770318a5679d41d8993ac8bb435b14f2dbda0 /CMakeLists.txt
parent[BUILD] add CMake targets to build binary and source packages with CPack (diff)
downloaddnbd3-b5445d3fae2fca61ed036a4e88f061903965db7a.tar.gz
dnbd3-b5445d3fae2fca61ed036a4e88f061903965db7a.tar.xz
dnbd3-b5445d3fae2fca61ed036a4e88f061903965db7a.zip
[BUILD] add systemd service file for dnbd3-server to installation targets
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dae49c6..fcdc6b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -161,7 +161,11 @@ if(CMAKE_BUILD_TYPE MATCHES Release)
"/lib/modules"
"/lib/modules/${CMAKE_SYSTEM_VERSION}"
"/lib/modules/${CMAKE_SYSTEM_VERSION}/extra"
- "/etc")
+ "/etc"
+ "/usr"
+ "/usr/lib"
+ "/usr/lib/systemd"
+ "/usr/lib/systemd/system")
if(DNBD3_KERNEL_MODULE)
file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/package/rpm/post "depmod -a\n")
file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/package/rpm/postun "depmod -a\n")
@@ -195,5 +199,5 @@ endif(CMAKE_BUILD_TYPE MATCHES Release)
# add all dnbd3 related projects from the source code directory
add_subdirectory(src)
-# add configuration files for packaging purposes
-add_subdirectory(conf)
+# add configuration and operational files for packaging purposes
+add_subdirectory(pkg)