summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2021-03-11 16:47:05 +0100
committerManuel Bentele2021-03-11 18:18:27 +0100
commitba20fa121a0e97a7862aa163a11c7337a05188f7 (patch)
treedff557d5524b711a6f90209f071ed7d3a4b38148 /CMakeLists.txt
parent[BUILD] Add Github workflow to validate (lint) source code (diff)
downloaddnbd3-ba20fa121a0e97a7862aa163a11c7337a05188f7.tar.gz
dnbd3-ba20fa121a0e97a7862aa163a11c7337a05188f7.tar.xz
dnbd3-ba20fa121a0e97a7862aa163a11c7337a05188f7.zip
[BUILD] Enable lint targets if lint programs are found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 1 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ecefc0..fb4d5d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,7 +20,6 @@ OPTION(DNBD3_SERVER_DEBUG_LOCKS "Add lock debugging code to dnbd3-server" OFF)
OPTION(DNBD3_SERVER_DEBUG_THREADS "Add thread debugging code to dnbd3-server" OFF)
OPTION(DNBD3_RELEASE_HARDEN "Compile dnbd3 programs in Release build with code hardening options" OFF)
OPTION(DNBD3_PACKAGE_DOCKER "Enable packaging of Docker image" OFF)
-OPTION(DNBD3_LINT "Enable source code linting and formatting with clang-format" OFF)
# set supported build configurations
set(CMAKE_CONFIGURATION_TYPES Debug Release)
@@ -38,18 +37,7 @@ find_package(Threads REQUIRED)
# include project version and build type related macros
include(Version)
include(Build)
-if(DNBD3_LINT)
- include(Lint)
-else()
- macro(add_linter LINT_NAME LINT_SOURCE_FILES)
- endmacro()
- macro(add_linter_fix LINT_NAME LINT_SOURCE_FILES)
- endmacro()
- macro(add_kernel_linter LINT_NAME LINT_SOURCE_FILES)
- endmacro()
- macro(add_kernel_linter_fix LINT_NAME LINT_SOURCE_FILES)
- endmacro()
-endif(DNBD3_LINT)
+include(Lint)
# check for system and enable or disable built of Linux kernel module
if(DNBD3_KERNEL_MODULE AND UNIX AND CMAKE_SYSTEM_NAME MATCHES "Linux")