summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Rettberg2019-09-09 17:43:20 +0200
committerSimon Rettberg2019-09-09 17:43:20 +0200
commitc2209762259426a8e5a25a6789711f76b4dca569 (patch)
treecd1d899a28f4a1c2938cde71ecd61d99efebad76 /CMakeLists.txt
parentcmake: Add some flags that enable exploit mitigation techniques (diff)
downloaddnbd3-c2209762259426a8e5a25a6789711f76b4dca569.tar.gz
dnbd3-c2209762259426a8e5a25a6789711f76b4dca569.tar.xz
dnbd3-c2209762259426a8e5a25a6789711f76b4dca569.zip
Fix compilation on older gcc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 26d4d38..1e75f2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,7 +42,7 @@ if(CMAKE_C_COMPILER MATCHES "clang")
SET(CMAKE_C_FLAGS_RELEASE " -O3 -Wno-unused-result -DNDEBUG")
elseif (CMAKE_C_COMPILER MATCHES "(cc-)|(cc$)")
message( "Using (g)cc flags." )
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fstack-clash-protection -mmitigate-rop")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mmitigate-rop")
SET(CMAKE_C_FLAGS_DEBUG " -O0 -g -Wall -Wextra -Wpedantic -Wconversion -Wno-sign-conversion -D_DEBUG")
SET(CMAKE_C_FLAGS_RELEASE " -O3 -Wno-unused-result -DNDEBUG")
else()