summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Rettberg2013-07-31 21:45:00 +0200
committerSimon Rettberg2013-07-31 21:45:00 +0200
commite7b3781c3e5c105fcd80a75546b9ab75eae8a2c9 (patch)
tree90e523671bb2ea349639b744b5bc3ee81f512fb7 /CMakeLists.txt
parent[SERVER] Still working on the uplink... Almost there (diff)
downloaddnbd3-e7b3781c3e5c105fcd80a75546b9ab75eae8a2c9.tar.gz
dnbd3-e7b3781c3e5c105fcd80a75546b9ab75eae8a2c9.tar.xz
dnbd3-e7b3781c3e5c105fcd80a75546b9ab75eae8a2c9.zip
[SERVER] Uplink handing complete (untested, as alt servers can't be defined yet, so prepare for lots of fixes ;))
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b4b43d..596fa43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,9 @@ TARGET_LINK_LIBRARIES(dnbd3-client)
FILE(GLOB_RECURSE SERVER_SRCS src/server/*.c)
ADD_EXECUTABLE(dnbd3-server ${SERVER_SRCS})
TARGET_LINK_LIBRARIES(dnbd3-server ${CMAKE_THREAD_LIBS_INIT} ${ZLIB_LIBRARIES})
+if(UNIX AND NOT APPLE)
+ target_link_libraries(dnbd3-server rt)
+endif()