summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-11-20 08:16:25 +0100
committerManuel Bentele2020-11-20 08:16:25 +0100
commitf00717d56cb3078d90fb096f7771d17b4fa19fb5 (patch)
tree0f96ebf6cef2a16edb9cdf34aba650f1965d74df /CMakeLists.txt
parent[KERNEL] Fix several connect/disconnect race conditions (diff)
downloaddnbd3-f00717d56cb3078d90fb096f7771d17b4fa19fb5.tar.gz
dnbd3-f00717d56cb3078d90fb096f7771d17b4fa19fb5.tar.xz
dnbd3-f00717d56cb3078d90fb096f7771d17b4fa19fb5.zip
[BUILD] add support for atomic operations not supported by hardware
This change links the dnbd3-server with 'libatomic' to add support for atomic operations not supported by hardware (especially 32-bit hardware architectures, such as ARM). Thus the dnbd3-server can also run on a Raspberry Pi 1 running Rasperry Pi OS. Note that the dnbd3-server is still linked to the libatomic, even if the hardware supports atomic operations. In this case, the compiler resolves atomic operations and replaces them automatically with specific built-in functions. This unnecessary linkage can be removed in the future if the GCC supports an upcoming option called automatic linking of libatomic (--enable-autolink-libatomic).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bad9c00..65b9ebb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -132,7 +132,7 @@ if(CMAKE_BUILD_TYPE MATCHES Release)
set(CPACK_RESOURCE_FILE_README ${CMAKE_CURRENT_SOURCE_DIR}/README.md)
# set DEB generator specific packaging options
- set(CPACK_DEBIAN_PACKAGE_DEPENDS "libc6, libfuse2, libjansson4")
+ set(CPACK_DEBIAN_PACKAGE_DEPENDS "libc6, libfuse2, libjansson4, libatomic1")
if(DNBD3_KERNEL_MODULE)
file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/package/deb/postinst "depmod -a\n")
file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/package/deb/postrm "depmod -a\n")
@@ -141,7 +141,7 @@ if(CMAKE_BUILD_TYPE MATCHES Release)
endif(DNBD3_KERNEL_MODULE)
# set RPM generator specific packaging options
- set(CPACK_RPM_PACKAGE_REQUIRES "glibc, fuse-libs, jansson")
+ set(CPACK_RPM_PACKAGE_REQUIRES "glibc, fuse-libs, jansson, libatomic")
set(CPACK_RPM_EXCLUDE_FROM_AUTO_FILELIST_ADDITION "/lib"
"/lib/modules"
"/lib/modules/${CMAKE_SYSTEM_VERSION}"