summaryrefslogtreecommitdiffstats
path: root/pkg/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-10-22 19:00:52 +0200
committerManuel Bentele2020-10-22 19:00:52 +0200
commitb5445d3fae2fca61ed036a4e88f061903965db7a (patch)
treebf4770318a5679d41d8993ac8bb435b14f2dbda0 /pkg/CMakeLists.txt
parent[BUILD] add CMake targets to build binary and source packages with CPack (diff)
downloaddnbd3-b5445d3fae2fca61ed036a4e88f061903965db7a.tar.gz
dnbd3-b5445d3fae2fca61ed036a4e88f061903965db7a.tar.xz
dnbd3-b5445d3fae2fca61ed036a4e88f061903965db7a.zip
[BUILD] add systemd service file for dnbd3-server to installation targets
Diffstat (limited to 'pkg/CMakeLists.txt')
-rw-r--r--pkg/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/pkg/CMakeLists.txt b/pkg/CMakeLists.txt
new file mode 100644
index 0000000..3112696
--- /dev/null
+++ b/pkg/CMakeLists.txt
@@ -0,0 +1,7 @@
+cmake_minimum_required(VERSION 3.10)
+
+# set the project name
+project(dnbd3-pkg)
+
+add_subdirectory(config)
+add_subdirectory(systemd)