summaryrefslogtreecommitdiffstats
path: root/src/fuse/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2020-10-19 14:35:01 +0200
committerManuel Bentele2020-10-19 14:44:05 +0200
commitf617270a773669885f263e394f8a10553e110e28 (patch)
treee2b8effab564350324aeebb5fcec3b9f1ba304af /src/fuse/CMakeLists.txt
parent[BUILD] rewrite CMake build system to track changes of source files (diff)
downloaddnbd3-f617270a773669885f263e394f8a10553e110e28.tar.gz
dnbd3-f617270a773669885f263e394f8a10553e110e28.tar.xz
dnbd3-f617270a773669885f263e394f8a10553e110e28.zip
[BUILD] fixes issues to build user space programs on FreeBSD 12.1
Diffstat (limited to 'src/fuse/CMakeLists.txt')
-rw-r--r--src/fuse/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/fuse/CMakeLists.txt b/src/fuse/CMakeLists.txt
index 367356a..1c107ed 100644
--- a/src/fuse/CMakeLists.txt
+++ b/src/fuse/CMakeLists.txt
@@ -4,7 +4,7 @@ cmake_minimum_required(VERSION 3.10)
project(dnbd3-fuse)
# add compile option to enable enhanced POSIX pthread features
-add_compile_options(-D_GNU_SOURCE)
+add_definitions(-D_GNU_SOURCE)
add_executable(dnbd3-fuse ${CMAKE_CURRENT_SOURCE_DIR}/connection.c
${CMAKE_CURRENT_SOURCE_DIR}/helper.c