summaryrefslogtreecommitdiffstats
path: root/src/server/picohttpparser/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Bentele2021-03-11 17:05:24 +0100
committerManuel Bentele2021-03-11 18:18:37 +0100
commitf5a3dd5fa08f39c2331e0a4faf42ece96dc3d93b (patch)
treec2668341163510210832887b91c301dd9b712d99 /src/server/picohttpparser/CMakeLists.txt
parent[BUILD] Enable lint targets if lint programs are found (diff)
downloaddnbd3-f5a3dd5fa08f39c2331e0a4faf42ece96dc3d93b.tar.gz
dnbd3-f5a3dd5fa08f39c2331e0a4faf42ece96dc3d93b.tar.xz
dnbd3-f5a3dd5fa08f39c2331e0a4faf42ece96dc3d93b.zip
[BUILD] Build picohttpparser as independent library
Diffstat (limited to 'src/server/picohttpparser/CMakeLists.txt')
-rw-r--r--src/server/picohttpparser/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/server/picohttpparser/CMakeLists.txt b/src/server/picohttpparser/CMakeLists.txt
new file mode 100644
index 0000000..cc6ec96
--- /dev/null
+++ b/src/server/picohttpparser/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 3.10)
+
+# set the project name
+project(picohttpparser
+ LANGUAGES C)
+
+set(PICOHTTPPARSER_SOURCE_FILES ${CMAKE_CURRENT_SOURCE_DIR}/picohttpparser.c)
+set(PICOHTTPPARSER_HEADER_FILES ${CMAKE_CURRENT_SOURCE_DIR}/picohttpparser.h)
+
+add_library(picohttpparser STATIC ${PICOHTTPPARSER_SOURCE_FILES})
+target_include_directories(picohttpparser PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})