summaryrefslogtreecommitdiffstats
path: root/conf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'conf/CMakeLists.txt')
-rw-r--r--conf/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/conf/CMakeLists.txt b/conf/CMakeLists.txt
new file mode 100644
index 0000000..1b888e6
--- /dev/null
+++ b/conf/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.10)
+
+# set the project name
+project(dnbd3-conf)
+
+# define all configuration files
+set(DNBD3_CONF_FILES ${CMAKE_CURRENT_SOURCE_DIR}/alt-servers
+ ${CMAKE_CURRENT_SOURCE_DIR}/rpc.acl
+ ${CMAKE_CURRENT_SOURCE_DIR}/server.conf)
+
+# install configuration files into sample directory
+install(FILES ${DNBD3_CONF_FILES} DESTINATION /etc/dnbd3-server/sample
+ COMPONENT server)