summaryrefslogtreecommitdiffstats
path: root/pkg/config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pkg/config/CMakeLists.txt')
-rw-r--r--pkg/config/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/pkg/config/CMakeLists.txt b/pkg/config/CMakeLists.txt
new file mode 100644
index 0000000..efbd2bf
--- /dev/null
+++ b/pkg/config/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 3.10)
+
+# set the project name
+project(dnbd3-config
+ LANGUAGES C)
+
+# define all configuration files
+set(DNBD3_CONFIG_FILES ${CMAKE_CURRENT_SOURCE_DIR}/alt-servers
+ ${CMAKE_CURRENT_SOURCE_DIR}/rpc.acl
+ ${CMAKE_CURRENT_SOURCE_DIR}/server.conf)
+
+# install configuration files into sample directory
+install(FILES ${DNBD3_CONFIG_FILES}
+ DESTINATION /etc/dnbd3-server/sample
+ COMPONENT server)