summaryrefslogtreecommitdiffstats
path: root/src/bench/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/bench/CMakeLists.txt')
-rw-r--r--src/bench/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/bench/CMakeLists.txt b/src/bench/CMakeLists.txt
new file mode 100644
index 0000000..d8a5dc9
--- /dev/null
+++ b/src/bench/CMakeLists.txt
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 3.10)
+
+# set the project name
+project(dnbd3-bench)
+
+# add compile option to enable enhanced POSIX pthread features
+add_compile_options(-D_GNU_SOURCE)
+
+add_executable(dnbd3-bench ${CMAKE_CURRENT_SOURCE_DIR}/connection.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/helper.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/main.c)
+target_link_libraries(dnbd3-bench dnbd3-version dnbd3-shared ${CMAKE_THREAD_LIBS_INIT})
+install(TARGETS dnbd3-bench RUNTIME DESTINATION bin)