summaryrefslogtreecommitdiffstats
path: root/src/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/client/CMakeLists.txt')
-rw-r--r--src/client/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/client/CMakeLists.txt b/src/client/CMakeLists.txt
new file mode 100644
index 0000000..a7c1eb4
--- /dev/null
+++ b/src/client/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.10)
+
+# set the project name
+project(dnbd3-client)
+
+# suppress -Wmultichar warnings
+add_compile_options(-Wno-multichar)
+
+# add compile option to enable enhanced BSD netdb features
+add_compile_options(-D_GNU_SOURCE)
+
+add_executable(dnbd3-client ${CMAKE_CURRENT_SOURCE_DIR}/client.c)
+target_link_libraries(dnbd3-client dnbd3-version dnbd3-shared)
+install(TARGETS dnbd3-client RUNTIME DESTINATION bin)