summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Rettberg2017-12-15 14:20:44 +0100
committerSimon Rettberg2017-12-15 14:20:44 +0100
commit385c59f19f71b080ca21f16322046db8165e55ff (patch)
tree0873131160c478b8227302354a062ad4cad17b30 /CMakeLists.txt
parentUpdate to CMAKE, fix timeout dialog on Qt5, fix menu getting covered by window (diff)
downloadbeamergui-385c59f19f71b080ca21f16322046db8165e55ff.tar.gz
beamergui-385c59f19f71b080ca21f16322046db8165e55ff.tar.xz
beamergui-385c59f19f71b080ca21f16322046db8165e55ff.zip
German translation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 10 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8ca1ac..b872522 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,16 @@ set(CMAKE_CXX_STANDARD 11)
# Some cmake versions can't understand the CMAKE_CXX_STANDARD option above?
SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11" )
+#
+# Qt5
+#
+FIND_PACKAGE(Qt5 COMPONENTS Widgets LinguistTools REQUIRED)
+FIND_PACKAGE(X11 REQUIRED)
+
+if(NOT X11_Xrandr_FOUND)
+ MESSAGE( FATAL_ERROR "Cannot find xrandr libs" )
+endif()
+
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
@@ -49,15 +59,6 @@ endif(BEAMERGUI_TSS)
# ${CMAKE_CURRENT_BINARY_DIR}
#)
-#
-# Qt5
-#
-FIND_PACKAGE(Qt5 COMPONENTS Widgets REQUIRED)
-FIND_PACKAGE(X11 REQUIRED)
-
-if(NOT X11_Xrandr_FOUND)
- MESSAGE( FATAL_ERROR "Cannot find xrandr libs" )
-endif()
QT5_WRAP_UI(BEAMERGUI_UI_HEADERS ${BEAMERGUI_UIS})