summaryrefslogtreecommitdiffstats
path: root/Config.in
diff options
context:
space:
mode:
authorPeter Korsgaard2008-08-04 21:07:05 +0200
committerPeter Korsgaard2008-08-04 21:07:05 +0200
commit02a623ddf96aa97c341a287bbb4ec5370a069444 (patch)
tree6923139fb98dd1d2e99b456503b37d4dd92e1136 /Config.in
parentbusybox: default HIDE_OTHERS to y for all versions (diff)
downloadbuildroot-02a623ddf96aa97c341a287bbb4ec5370a069444.tar.gz
buildroot-02a623ddf96aa97c341a287bbb4ec5370a069444.tar.xz
buildroot-02a623ddf96aa97c341a287bbb4ec5370a069444.zip
buildroot: remove trailing spaces
for i in `find -name 'Config*' -o -name 'Makefile*' -o -name '*.mk'`; do sed -i 's/ \+$//' $i; done
Diffstat (limited to 'Config.in')
-rw-r--r--Config.in66
1 files changed, 33 insertions, 33 deletions
diff --git a/Config.in b/Config.in
index b49425ce5..5522b7cff 100644
--- a/Config.in
+++ b/Config.in
@@ -207,9 +207,9 @@ choice
config BR2_DEBUG_1
bool "debug level 1"
help
- Debug level 1 produces minimal information, enough
- for making backtraces in parts of the program that
- you don't plan to debug. This includes descriptions
+ Debug level 1 produces minimal information, enough
+ for making backtraces in parts of the program that
+ you don't plan to debug. This includes descriptions
of functions and external variables, but no information
about local variables and no line numbers.
@@ -221,7 +221,7 @@ config BR2_DEBUG_2
config BR2_DEBUG_3
bool "debug level 3"
help
- Level 3 includes extra information, such as all the
+ Level 3 includes extra information, such as all the
macro definitions present in the program. Some debuggers
support macro expansion when you use -g3.
endchoice
@@ -266,41 +266,41 @@ config BR2_OPTIMIZE_0
bool "optimization level 0"
depends on !BR2_PACKAGE_LINUX
help
- Do not optimize. This is the default.
+ Do not optimize. This is the default.
config BR2_OPTIMIZE_1
bool "optimization level 1"
depends on !BR2_PACKAGE_LINUX
help
- Optimize. Optimizing compilation takes somewhat more time,
- and a lot more memory for a large function. With -O, the
- compiler tries to reduce code size and execution time,
- without performing any optimizations that take a great deal
- of compilation time. -O turns on the following optimization
- flags: -fdefer-pop -fdelayed-branch -fguess-branch-probability
- -fcprop-registers -floop-optimize -fif-conversion
- -fif-conversion2 -ftree-ccp -ftree-dce -ftree-dominator-opts
- -ftree-dse -ftree-ter -ftree-lrs -ftree-sra -ftree-copyrename
+ Optimize. Optimizing compilation takes somewhat more time,
+ and a lot more memory for a large function. With -O, the
+ compiler tries to reduce code size and execution time,
+ without performing any optimizations that take a great deal
+ of compilation time. -O turns on the following optimization
+ flags: -fdefer-pop -fdelayed-branch -fguess-branch-probability
+ -fcprop-registers -floop-optimize -fif-conversion
+ -fif-conversion2 -ftree-ccp -ftree-dce -ftree-dominator-opts
+ -ftree-dse -ftree-ter -ftree-lrs -ftree-sra -ftree-copyrename
-ftree-fre -ftree-ch -funit-at-a-time -fmerge-constants
- -O also turns on -fomit-frame-pointer on machines where doing
+ -O also turns on -fomit-frame-pointer on machines where doing
so does not interfere with debugging.
config BR2_OPTIMIZE_2
bool "optimization level 2"
help
Optimize even more. GCC performs nearly all supported optimizations
- that do not involve a space-speed tradeoff. The compiler does not
- perform loop unrolling or function inlining when you specify -O2.
- As compared to -O, this option increases both compilation time and
- the performance of the generated code. -O2 turns on all optimization
- flags specified by -O. It also turns on the following optimization
- flags: -fthread-jumps -fcrossjumping -foptimize-sibling-calls
- -fcse-follow-jumps -fcse-skip-blocks -fgcse -fgcse-lm
- -fexpensive-optimizations -fstrength-reduce -frerun-cse-after-loop
- -frerun-loop-opt -fcaller-saves -fpeephole2 -fschedule-insns
- -fschedule-insns2 -fsched-interblock -fsched-spec -fregmove
- -fstrict-aliasing -fdelete-null-pointer-checks -freorder-blocks
- -freorder-functions -falign-functions -falign-jumps -falign-loops
+ that do not involve a space-speed tradeoff. The compiler does not
+ perform loop unrolling or function inlining when you specify -O2.
+ As compared to -O, this option increases both compilation time and
+ the performance of the generated code. -O2 turns on all optimization
+ flags specified by -O. It also turns on the following optimization
+ flags: -fthread-jumps -fcrossjumping -foptimize-sibling-calls
+ -fcse-follow-jumps -fcse-skip-blocks -fgcse -fgcse-lm
+ -fexpensive-optimizations -fstrength-reduce -frerun-cse-after-loop
+ -frerun-loop-opt -fcaller-saves -fpeephole2 -fschedule-insns
+ -fschedule-insns2 -fsched-interblock -fsched-spec -fregmove
+ -fstrict-aliasing -fdelete-null-pointer-checks -freorder-blocks
+ -freorder-functions -falign-functions -falign-jumps -falign-loops
-falign-labels -ftree-vrp -ftree-pre
Please note the warning under -fgcse about invoking -O2 on programs
that use computed gotos.
@@ -308,20 +308,20 @@ config BR2_OPTIMIZE_2
config BR2_OPTIMIZE_3
bool "optimization level 3"
help
- Optimize yet more. -O3 turns on all optimizations specified by -O2
- and also turns on the -finline-functions, -funswitch-loops and
+ Optimize yet more. -O3 turns on all optimizations specified by -O2
+ and also turns on the -finline-functions, -funswitch-loops and
-fgcse-after-reload options.
config BR2_OPTIMIZE_S
bool "optimize for size"
help
- Optimize for size. -Os enables all -O2 optimizations that do not
+ Optimize for size. -Os enables all -O2 optimizations that do not
typically increase code size. It also performs further optimizations
- designed to reduce code size. -Os disables the following optimization
- flags: -falign-functions -falign-jumps -falign-loops -falign-labels
+ designed to reduce code size. -Os disables the following optimization
+ flags: -falign-functions -falign-jumps -falign-loops -falign-labels
-freorder-blocks -freorder-blocks-and-partition -fprefetch-loop-arrays
-ftree-vect-loop-version
-
+
endchoice
config BR2_PREFER_STATIC_LIB