summaryrefslogtreecommitdiffstats
path: root/Config.in
diff options
context:
space:
mode:
authorUlf Samuelsson2007-07-12 15:11:03 +0200
committerUlf Samuelsson2007-07-12 15:11:03 +0200
commit412ca2a4d4072b5d4d2fa819d62f6a8848ff7fda (patch)
tree0181b9f0673b2cbe494b4ef025aac7cfb26649c0 /Config.in
parentDefine date of build as DATE, use in mtd/mtd.mk (diff)
downloadbuildroot-412ca2a4d4072b5d4d2fa819d62f6a8848ff7fda.tar.gz
buildroot-412ca2a4d4072b5d4d2fa819d62f6a8848ff7fda.tar.xz
buildroot-412ca2a4d4072b5d4d2fa819d62f6a8848ff7fda.zip
BSP Patch:
========================================================= The purpose of the BSP patch is to allow building several boards inside the same buildroot tree. For this to work, each board has to have its own "$(TARGET_DIR)" and all *configurable* packages must be rebuilt for each board. They are now built in the "$(PROJECT_BUILD_DIR)" All non configurable packages can and should still be built in the "$(BUILD_DIR)". If a package is built for one board, then when you build for a second board of the same architecture the build becomes a simple copy of the resulting binaries. ----- Define BR2_PROJECT which will be used as the selector between different boards. Note that BR2_PROJECT allow you to build multiple root file systems for a single board, and should not be confused with BR2_BOARD_NAME which relates to the H/W. ----- Define PROJECT_BUILD_DIR as "PROJECT_BUILD_DIR/$(PROJECT)" Define BINARIES_DIR as "binaries/$(PROJECT)" Define TARGET_DIR as "$(PROJECT_BUILD_DIR)/root" (some prefix/postfix may apply) Resulting images are stored in "$(BINARIES_DIR)" ----- Define a few new environment variables in Makefile PROJECT: Stripped BR2_PROJECT DATE: Date of build in YYYY-MM-DD format HOSTNAME: Stripped BR2_HOSTNAME => /etc/hostname BANNER: Stripped BR2_BANNER => /etc/issue Linux and Busybox will be built in $(PROJECT_BUILD_DIR) More patches will be needed later to ensure all configurable packages are built in this directory.
Diffstat (limited to 'Config.in')
-rw-r--r--Config.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index fec832f1c..1ddb474c8 100644
--- a/Config.in
+++ b/Config.in
@@ -6,6 +6,8 @@ config BR2_HAVE_DOT_CONFIG
bool
default y
+source "project/Config.in"
+
choice
prompt "Target Architecture"
default BR2_i386