summaryrefslogtreecommitdiffstats
path: root/Config.in
diff options
context:
space:
mode:
authorDaniel Laird2008-11-28 15:20:47 +0100
committerDaniel Laird2008-11-28 15:20:47 +0100
commit5432f26f0e78fc74a599a596c90a3b8f02963c13 (patch)
treea2f18f774cc9afe12770bb3037e4c5b063e1b3fa /Config.in
parentbusybox: updated 1.13.0 ash fix (diff)
downloadbuildroot-5432f26f0e78fc74a599a596c90a3b8f02963c13.tar.gz
buildroot-5432f26f0e78fc74a599a596c90a3b8f02963c13.tar.xz
buildroot-5432f26f0e78fc74a599a596c90a3b8f02963c13.zip
Adding Central config.cache options
The following changes allow for use of a central configure cache file. This speeds up configuration of packages. Its use is configurable at the top level (BR2_CONFIG_CACHE - default n). Old style makefiles can use it if they use the following MACRO in makefiles: $(AUTO_CONFIGURE_TARGET) see my change to directfb.mk. New style Autotools.in will use it if you set the global option. However you can enable the global option and on a per package overrule it by doing the following: $(PKGNAME)_USE_CONFIG_CACHE = NO see fontconfig.mk for an example of this. Finally I have removed a few config variable settings which indicated no CXX compiler as this is wrong and breaks the build when using this central cache. Config.in | 8 ++++++++ package/Makefile.autotools.in | 5 ++++- package/Makefile.in | 28 +++++++++++++++++++++++++++- package/atk/atk.mk | 2 +- package/directfb/directfb.mk | 7 +------ package/fontconfig/fontconfig.mk | 3 +++ package/libglib2/libglib2.mk | 2 +- package/libgtk2/libgtk2.mk | 1 - 8 files changed, 45 insertions(+), 11 deletions(-) I would appreciate feedback on this change (I have been testing for 2-3 weeks) But I can never test all cases! If you enable the BR2_CONFIG_CACHE option some Makefile.autotools.in based packages may now break - I cannot build them all. In this case you may need to remove config options that are being hardcoded all over the place (like gtk saying we have 2 CXX compiler) or disable the use of CONFIG CACHE file like I have done in fontconfig. I can build all packages required to get WebKit on DirectFB up and running and it runs fine. I will try to resolve any issues this creates as fast as I can. Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
Diffstat (limited to 'Config.in')
-rw-r--r--Config.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index ddbe43b9a..353b3815c 100644
--- a/Config.in
+++ b/Config.in
@@ -189,6 +189,14 @@ config BR2_RECENT
help
This option show recent versions of packages.
+config BR2_CONFIG_CACHE
+ bool "Use a central configure cache file"
+ default n
+ help
+ This determines if a central config cache is used by
+ packages, reducing the configure time for packages as each
+ one caches its findings.
+
config BR2_ENABLE_DEBUG
bool "build packages with debugging symbols"
select BR2_PACKAGE_GDB_SERVER