summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
author"Steven J. Hill"2007-02-06 19:19:38 +0100
committer"Steven J. Hill"2007-02-06 19:19:38 +0100
commit02f71aab47835e7220e2b1039bcda4d0c5657db0 (patch)
treec4a14c8fb83fdec69a34065d93777e9960ea0831 /Makefile
parentFix building of GDB when using external toolchain. (diff)
downloadbuildroot-02f71aab47835e7220e2b1039bcda4d0c5657db0.tar.gz
buildroot-02f71aab47835e7220e2b1039bcda4d0c5657db0.tar.xz
buildroot-02f71aab47835e7220e2b1039bcda4d0c5657db0.zip
Support building using an external toolchain. Questions to the mailing list and all other comments to <biteme@devnull.com>.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7a0253b5b..80e314c6a 100644
--- a/Makefile
+++ b/Makefile
@@ -44,7 +44,11 @@ ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
# along with the packages to build for the target.
#
##############################################################
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
TARGETS:=uclibc-configured binutils gcc uclibc-target-utils
+else
+TARGETS:=uclibc
+endif
include toolchain/Makefile.in
include package/Makefile.in