summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorManuel Novoa III2004-02-18 09:28:28 +0100
committerManuel Novoa III2004-02-18 09:28:28 +0100
commit04eadcdcc2d09ace98041ba1fcb9d207a4300bc3 (patch)
treec4b5bad2b34071ec913f994ac605f4461b48eece /Makefile
parentUpgrade since 2.5.4 has a configuration bug which builds with largefiles (diff)
downloadbuildroot-04eadcdcc2d09ace98041ba1fcb9d207a4300bc3.tar.gz
buildroot-04eadcdcc2d09ace98041ba1fcb9d207a4300bc3.tar.xz
buildroot-04eadcdcc2d09ace98041ba1fcb9d207a4300bc3.zip
Update binutils from 2.14.90.0.6 to 2.14.90.0.8.
Update from gcc 3.3.2 to 3.3.3. Test builds done for i386 and mipsel (3.3.3) and i386 (2.95). Soft float support not yet tested with 3.3.3.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index fe6e0b821..bb162a2e5 100644
--- a/Makefile
+++ b/Makefile
@@ -159,7 +159,7 @@ TARGETS+=busybox tinylogin
#If you want a development system, you probably want gcc built
# with uClibc so it can run within your dev system...
-#TARGETS+=gcc2_95_target ccache_target
+#TARGETS+=gcc2_95_target ccache_target # NOT WORKING!!!
#TARGETS+=gcc3_3_target ccache_target
# Of course, if you are installing a development system, you
@@ -311,13 +311,9 @@ $(STAGING_DIR):
rm -rf $(STAGING_DIR)
mkdir -p $(STAGING_DIR)/lib
mkdir -p $(STAGING_DIR)/usr
-ifneq ($(GCC_2_95_TOOLCHAIN),true)
- mkdir -p $(STAGING_DIR)/include
-else
- mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/include
- (cd $(STAGING_DIR); ln -fs $(REAL_GNU_TARGET_NAME)/include)
-endif
+ ln -fs $(REAL_GNU_TARGET_NAME)/include $(STAGING_DIR)/include
ln -fs ../lib $(STAGING_DIR)/usr/lib
+ ln -fs ../$(REAL_GNU_TARGET_NAME)/include $(STAGING_DIR)/usr/include
$(TARGET_DIR):
rm -rf $(TARGET_DIR)