summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJason Spence2008-03-28 03:50:42 +0100
committerJason Spence2008-03-28 03:50:42 +0100
commit0d17acf4cffd53e9eb21096e037b1f96d190780a (patch)
tree46cbe50b7701ec213d867fcf80625183600110ef /Makefile
parentgcc 4.2.1: fix undefined reference to fmsub in C++ programs with soft float (diff)
downloadbuildroot-0d17acf4cffd53e9eb21096e037b1f96d190780a.tar.gz
buildroot-0d17acf4cffd53e9eb21096e037b1f96d190780a.tar.xz
buildroot-0d17acf4cffd53e9eb21096e037b1f96d190780a.zip
Added ccache support and removed grub from defconfig due to brokenness at the moment.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 1aca7885a..9f9f0628d 100644
--- a/Makefile
+++ b/Makefile
@@ -78,6 +78,11 @@ CONFIG_SHELL:=$(shell if [ -x "$$BASH" ]; then echo $$BASH; \
export CONFIG_SHELL quiet Q KBUILD_VERBOSE VERBOSE
+HOSTCCACHE:=$(shell $(CONFIG_SHELL) -c "which ccache")
+ifneq ($(HOSTCCACHE),)
+BR2_HAVE_HOST_CCACHE=y
+endif
+
ifndef HOSTAR
HOSTAR:=ar
endif
@@ -124,6 +129,12 @@ endif
ifndef FCFLAGS_FOR_BUILD
FCFLAGS_FOR_BUILD:=-g -O2
endif
+
+ifeq ($(BR2_HAVE_HOST_CCACHE),y)
+HOSTCC:=$(HOSTCCACHE) $(HOSTCC)
+HOSTCXX:=$(HOSTCCACHE) $(HOSTCXX)
+endif
+
export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTFC HOSTLD