summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGustavo Zacarias2010-11-30 16:19:59 +0100
committerPeter Korsgaard2010-11-30 16:28:41 +0100
commit0dc940cdeeaa1fae3510ff8a1b581f4ecf27b5c4 (patch)
treeb696e633fb648282b47b96c52899e7a6e21cf865 /Makefile
parentboot/syslinux: allow build on x86_64 (diff)
downloadbuildroot-0dc940cdeeaa1fae3510ff8a1b581f4ecf27b5c4.tar.gz
buildroot-0dc940cdeeaa1fae3510ff8a1b581f4ecf27b5c4.tar.xz
buildroot-0dc940cdeeaa1fae3510ff8a1b581f4ecf27b5c4.zip
Makefile: introduce KSTRIPCMD to strip kernel modules
When sstrip is selected it tries to strip kernel modules too. Unfortunately this fails with a "unrecognized program segment header size" error thus interrupting the build process. We introduce a new $(KSTRIPCMD) strip command for this, being a regular strip when sstrip is selected and an empty stub when not stripping. At the same time get rid of the REMOVE_SECTION_* variables, as they are only used once. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8dbb026b7..008bdf335 100644
--- a/Makefile
+++ b/Makefile
@@ -421,7 +421,7 @@ endif
find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db*.so*' | \
xargs $(STRIPCMD) 2>/dev/null || true
find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
- xargs -r $(STRIPCMD) $(STRIP_STRIP_UNNEEDED)
+ xargs -r $(KSTRIPCMD) || true
mkdir -p $(TARGET_DIR)/etc
# Mandatory configuration file and auxilliary cache directory