summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMike Frysinger2011-03-28 09:18:47 +0200
committerPeter Korsgaard2011-03-28 10:29:35 +0200
commit0df02e1233c5990391c030f40ab4263cfaa83a40 (patch)
tree1e435c7a294d025def869bc2058446add832500d /Makefile
parentexternal toolchain: Only prefix path if specified (diff)
downloadbuildroot-0df02e1233c5990391c030f40ab4263cfaa83a40.tar.gz
buildroot-0df02e1233c5990391c030f40ab4263cfaa83a40.tar.xz
buildroot-0df02e1233c5990391c030f40ab4263cfaa83a40.zip
hostcc/hostcxx: fix noccache variant setting
The current code accidentally sets up HOSTCC_NOCCACHE and HOSTCXX_NOCCACHE only when the respective HOSTCC or HOSTCXX values are not set. So if you do something like: make HOSTCC=gcc menuconfig The build fails because HOSTCC_NOCCACHE is not set anywhere. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 7ae3787bd..9aa7399f1 100644
--- a/Makefile
+++ b/Makefile
@@ -126,13 +126,13 @@ endif
ifndef HOSTCC
HOSTCC:=gcc
HOSTCC:=$(shell which $(HOSTCC) || type -p $(HOSTCC) || echo gcc)
-HOSTCC_NOCCACHE:=$(HOSTCC)
endif
+HOSTCC_NOCCACHE:=$(HOSTCC)
ifndef HOSTCXX
HOSTCXX:=g++
HOSTCXX:=$(shell which $(HOSTCXX) || type -p $(HOSTCXX) || echo g++)
-HOSTCXX_NOCCACHE:=$(HOSTCXX)
endif
+HOSTCXX_NOCCACHE:=$(HOSTCXX)
ifndef HOSTFC
HOSTFC:=gfortran
endif